Skip to main content

Upgrading webtrees

There are two ways to upgrade webtrees - manual and automatic.

If you are currently using a version of webtrees listed below, there are some additional instructions.

webtrees 2.0.8

webtrees 2.0.8 contains a bug in the auto-upgrade code. It was quickly withdrawn, but a few users have installed it. To use the automatic upgrade you need to edit two files.

Firstly, edit app/Factories/FilesystemFactory.php and change line 40 from '/../../..' to '/../..'. This fixes the bug.

Secondaly, edit app/Webtrees.php and change line 101 from '2.0.8' to '2.0.7'. This will enable the automatic upgrade.

webtrees 1.7.10 – 1.7.17

There are several important differences between webtrees 1.7 and webtrees 2.0. You should read them before upgrading, as you may need to make changes to your settings, your server configuration, or your workflow.

There is currently no automatic upgrade from webtrees 1.7 to webtrees 2.0, so you will need to follow the instructions for a manual upgrade.

webtrees 1.4.0 – 1.7.9

You cannot upgrade directly to webtrees 2.0.10. Instead, you must first upgrade to webtrees 1.7.17.

webtrees 1.0.0 – 1.3.2

You need to disable the “media firewall”. Then you should upgrade to webtrees 1.7.17.

phpGedView

There is a migration wizard built into webtrees 1.7.17. You should install this version, and then upgrade to webtrees 2.0.10. Note that you do not need to have a functioning phpGedView installation. You need only the database and the index/ folder.

Edit this page